home | help
EMIL.CF(1)		     General Commands Manual		      EMIL.CF(1)

NAME
     emil.cf - configuration file for emil(1)

SYNOPSIS
     group  Group_Name: [ charset= CHARSET , ] [ format= FORMAT , ] [ appletype=
     ENCODING , ] [ bin= ENCODING , ] [ textenc= ENCODING , ] [ henc= ENCODING ]
     ;

     match Context  Match_String  OUT ;

     member Group_Name :  Recipient  Sender  Recipient_host  , ... ;

     mailer Mailer_Name :  Path,  Program,  Arguments,	... ;

DESCRIPTION
     The file /usr/local/lib/emil.cf is used by emil(1) to decide which  conver-
     sions  should be applied to a specific Internet message. Conversion is con-
     trolled by the combination of Sender, Recipient and Recipient_host and  the
     corresponding group line.

     When emil is executed it first visits /usr/local/lib/emil.cf with the argu-
     ments  Sender,  Recipient	and Recipient_host to extract the name of target
     group (as specified by the member fields).  A  subsequent	check  with  the
     group fields yields the target group structure, containing charset, format,
     bin, textenc and henc.  Then the Sender and Recipient is swapped to get the
     corresponding information about the sender.

COMMANDS
     Commands may appear in any order. They are all ended with a semi colon ";".

	    group  Defines a group by a group name and a comma separated list of
		   options.

		   Group_name - Name of the group.

		   charset  - Specifies the charset used by the group, according
		   to RFC1345.

		   format - Specifies the format used by the  group.   Pick  one
		   of:	MIME,  MAILTOOL,  RFC822  or  TRANSPARENT.   Default  is
		   RFC822.

		   appletype - Specifies the format to be used for applefile at-
		   tachments.  Pick one of Binhex, appleDouble or appleSingle.

		   bin - Specifies the encoding to be used  for  binary  attach-
		   ments.  Pick one of BAse64, BInhex or Uuencode.

		   textenc  -  Specifies the encoding to be used for text.  Pick
		   one of BAse64, BInhex, Uuencode, Quoted-printable,  8bit,  Se
		   or  7bit.  7bit  is	default. When 7bit is chosen the text is
		   first converted to ISO-8859-1 and then  the	8bit  characters
		   are	replaced  by  the english characters with closest resem-
		   blance.  When Se is chosen the text	is  first  converted  to
		   ISO-8859-1  and  then the 8bit characters are replaced by the
		   appropriate characters as specified by some national variants
		   of ISO-646. This special conversion is suited to work in Swe-
		   den but works probably also for other european languages.

		   henc - Specifies the encoding to be used  for  header  lines.
		   Pick one of Base64, Quoted-printable, 8bit or Se, 7bit.  7bit
		   is default. If BAse64 or Quoted-Printable is selected headers
		   are	converted  according  to RFC1522 (MIME-II).  7bit and Se
		   behaves like in the textenc field.

	    match  This field is used to build a list of types	and  the  corre-
		   sponding expression in the given context.

		   Context - One of MAILTOOL, MIME, BINHEX or UUENCODE.

		   OUT - The generic type of the field

		   Match_String  -  A quoted string that corresponds to the Con-
		   text of the field. For MAILTOOL Match_String defines the  Sun
		   Mailtool  X-Sun-Data_type  to  be used. For MIME Match_String
		   defines  the  content-type	to   be   used.   For	UUENCODE
		   Match_String defines the file name extension to be used.  For
		   BINHEX Match_String defines the merged two 4byte strings Type
		   and Auth info.

	    member
		   Defines  members of a group given as a group name and a comma
		   separated list of the triples Recipient, Sender  and  Recipi-
		   ent_host.  Either one in the triples can be totally or partly
		   replaced by a wildcard '*'.

		   Group_name - Name of the group.

		   Sender - Sender's mail address.

		   Recipient - Recipient's mail address.

		   Recipient_host - Name of the recipient host or relay.

     mailer
	    Defines  a	mailer	(or tags a program) as a mailer name and a comma
	    separated list of arguments that makes up the execv  vector  of  the
	    program to execute.

	    Mailer_name - Name of the mailer.

	    Path - Path of the program to execute.

	    Program - Name of the program to execute

	    Arguments  - A list of each command line argument to use when invok-
	    ing the program.  To be suitable for mail programs you  can  specify
	    variables  representing  sender, recipient and mail relay. These are
	    specified by $s, $r and $x respectively.

AUTHOR
     Martin  Wendel  (Martin.Wendel@its.uu.se)	and  Torbjorn  Wictorin   (Torb-
     jorn.Wictorin@its.uu.se)

SEE ALSO
     emil(1)

BUGS
     None

				19 December 1994		      EMIL.CF(1)

home | help