Skip site navigation (1)Skip section navigation (2)

  
 
  

home | help
MMIME(1)		     General Commands Manual			MMIME(1)

NAME
     mmime -- create MIME messages

SYNOPSIS
     mmime [-c | -r] [-t content-type] < message

DESCRIPTION
     mmime  generates  a  `multipart/mixed' message from the standard input, ex-
     tending, wrapping, and encoding the  header  as  necessary,  and  replacing
     lines in the message body of the form

	   #content/type[#content-disposition] path[>filename]

     with  a  MIME part having Content-Type content/type, consisting of the con-
     tents of the file found at path.  content-disposition is optional	and  de-
     faults  to `attachment'.  filename is optional and defaults to the basename
     of path.

     The options are as follows:

     -c      Check mode: don't output anything, exit with status 1  if	MIME-en-
	     coding the message is required, or else exit with status 0.

     -r      Raw  mode:  don't	expand	MIME  parts  in  the  body,  generate  a
	     `text/plain' message.

     -t content-type
	     Override  Content-Type  for  the  toplevel   part.    Defaults   to
	     `multipart/mixed'.

ENVIRONMENT
     MBLAZE_RELAXED_MIME
	     If  set,  mmime  -c  will relax the body line length check and only
	     consider bodies with lines longer than 998 characters  need  to  be
	     MIME formatted.

EXIT STATUS
     The mmime utility exits 0 on success, and >0 if an error occurs.

SEE ALSO
     makemime(1), mhbuild(1)

     N.  Freed	and  N. Borenstein, Multipurpose Internet Mail Extensions (MIME)
     Part One: Format of Internet Message Bodies, RFC 2045, November 1996.

     N. Freed and N. Borenstein, Multipurpose Internet	Mail  Extensions  (MIME)
     Part Two: Media Types, RFC 2046, November 1996.

     K.  Moore, MIME (Multipurpose Internet Mail Extensions) Part Three: Message
     Header Extensions for Non-ASCII Text, RFC 2047, November 1996.

     N. Freed and K. Moore, MIME Parameter Value and  Encoded  Word  Extensions:
     Character Sets, Languages, and Continuations, RFC 2231, November 1997.

     P. Resnick (ed.), Internet Message Format, RFC 5322, October 2008.

AUTHORS
     Leah Neukirchen <leah@vuxu.org>

LICENSE
     mmime is in the public domain.

     To  the  extent possible under law, the creator of this work has waived all
     copyright and related or neighboring rights to this work.

     http://creativecommons.org/publicdomain/zero/1.0/

FreeBSD ports 15.quarterly	  July 22, 2016 			MMIME(1)

Want to link to this manual page? Use this URL:
<https://man.freebsd.org/cgi/man.cgi?query=mmime&sektion=1&manpath=FreeBSD+Ports+15.1.quarterly>

home | help