FreeBSD Manual Pages
VOP_LISTEXTATTR(9) BSD Kernel Developer's Manual VOP_LISTEXTATTR(9) NAME VOP_LISTEXTATTR -- retrieve a list of named extended attribute from a vn- ode SYNOPSIS #include <sys/param.h> #include <sys/vnode.h> #include <sys/extattr.h> int VOP_LISTEXTATTR(struct vnode *vp, int attrnamespace, struct uio *uio, size_t *size, struct ucred *cred, struct thread *td); DESCRIPTION This vnode call may be used to retrieve a list of named extended at- tributes from a specified namespace on a file or directory. Its arguments are: vp The vnode of the file or directory. attrnamespace Integer constant indicating which extended attribute name- space the attribute name is present in. uio The location of the data to be read. The resulting data will be a list of attribute names. Each list entry con- sists of a single byte containing the length of the attri- bute name, followed by the attribute name. The attribute name is not terminated by ASCII NUL. size If not NULL, on return it will contain the number of bytes required to read the list. In most cases uio will be NULL when size is not, and vise versa. cred The user credentials to use in authorizing the request. td The thread requesting the extended attribute. The cred pointer may be NULL to indicate that access control checks are not to be performed, if possible. This cred setting might be used to al- low the kernel to authorize extended attribute retrieval that the active process might not be permitted to do. Extended attribute semantics may vary by file system implementing the call. More information on extended attributes may be found in extattr(9). LOCKS The vnode will be locked on entry and should remain locked on return. RETURN VALUES On success, zero will be returned, and the uio structure will be updated to reflect the list read. Otherwise, an appropriate error code is re- turned. ERRORS [EACCES] The caller does not have the appropriate privilege. [ENXIO] The request was not valid in this file system for the specified vnode and attribute name. [ENOMEM] Sufficient memory is not available to fulfill the re- quest. [EFAULT] The uio structure refers to an invalid userspace ad- dress. [EINVAL] The namespace or uio argument is invalid. [EOPNOTSUPP] The file system does not support VOP_LISTEXTATTR(). SEE ALSO extattr(9), vnode(9), VOP_GETEXTATTR(9), VOP_SETEXTATTR(9) BSD August 19, 2005 BSD
NAME | SYNOPSIS | DESCRIPTION | LOCKS | RETURN VALUES | ERRORS | SEE ALSO
Want to link to this manual page? Use this URL:
<https://man.freebsd.org/cgi/man.cgi?query=VOP_LISTEXTATTR&sektion=9&manpath=FreeBSD+8.2-RELEASE>