FreeBSD Manual Pages
DEVCLASS_GET_DEVICES(9) BSD Kernel Developer's Manual DEVCLASS_GET_DEVICES(9) NAME devclass_get_devices -- get a list of devices in a devclass SYNOPSIS #include <sys/param.h> #include <sys/bus.h> int devclass_get_devices(devclass_t dc, device_t **devlistp, int *devcountp); DESCRIPTION Retrieve a list of all device instances currently in the devclass and re- turn the list in *devlistp and the count in *devcountp. The memory allo- cated for the list should be freed using free(*devlistp, M_TEMP), even if *devcountp is 0. RETURN VALUES Zero is returned on success, otherwise an appropriate error is returned. SEE ALSO devclass(9), device(9) AUTHORS This manual page was written by Doug Rabson. BSD May 19, 2005 BSD
NAME | SYNOPSIS | DESCRIPTION | RETURN VALUES | SEE ALSO | AUTHORS
Want to link to this manual page? Use this URL:
<https://man.freebsd.org/cgi/man.cgi?query=devclass_get_devices&sektion=9&manpath=FreeBSD+8.2-RELEASE>