FreeBSD Manual Pages
IFCONFIG(8) BSD System Manager's Manual IFCONFIG(8) NAME ifconfig -- configure network interface parameters SYNOPSIS ifconfig [-L] [-k] [-m] interface [create] [address_family] [address [dest_address]] [parameters] ifconfig interface destroy ifconfig -a [-L] [-d] [-m] [-u] [-v] [address_family] ifconfig -l [-d] [-u] [address_family] ifconfig [-L] [-d] [-k] [-m] [-u] [-v] [-C] DESCRIPTION The ifconfig utility is used to assign an address to a network interface and/or configure network interface parameters. The ifconfig utility must be used at boot time to define the network address of each interface present on a machine; it may also be used at a later time to redefine an interface's address or other operating parameters. The following options are available: address For the DARPA-Internet family, the address is either a host name present in the host name data base, hosts(5), or a DARPA Internet address expressed in the Internet standard "dot notation". It is also possible to use the CIDR notation (also known as the slash notation) to include the netmask. That is, one can specify an address like 192.168.0.1/16. For "inet6" family, it is also possible to specify the prefix length using the slash notation, like ::1/128. See the prefixlen parameter below for more information. The link-level ("link") address is specified as a series of colon-separated hex digits. This can be used to e.g. set a new MAC address on an ethernet interface, though the mechanism used is not ethernet-specific. If the interface is already up when this option is used, it will be briefly brought down and then brought back up again in order to ensure that the receive filter in the underlying ethernet hardware is properly reprogrammed. address_family Specify the address family which affects interpretation of the remaining parameters. Since an interface can receive transmis- sions in differing protocols with different naming schemes, spec- ifying the address family is recommended. The address or proto- col families currently supported are "inet", "inet6", "atalk", "ipx", and "link". The default is "inet". "ether" and "lladdr" are synonyms for "link". dest_address Specify the address of the correspondent on the other end of a point to point link. interface This parameter is a string of the form "name unit", for example, "ed0". The following parameters may be set with ifconfig: add Another name for the alias parameter. Introduced for compatibil- ity with BSD/OS. alias Establish an additional network address for this interface. This is sometimes useful when changing network numbers, and one wishes to accept packets addressed to the old interface. If the address is on the same subnet as the first network address for this in- terface, a non-conflicting netmask must be given. Usually 0xffffffff is most appropriate. -alias Remove the network address specified. This would be used if you incorrectly specified an alias, or it was no longer needed. If you have incorrectly set an NS address having the side effect of specifying the host portion, removing all NS addresses will allow you to respecify the host portion. anycast (Inet6 only.) Specify that the address configured is an anycast address. Based on the current specification, only routers may configure anycast addresses. Anycast address will not be used as source address of any of outgoing IPv6 packets. arp Enable the use of the Address Resolution Protocol (arp(4)) in mapping between network level addresses and link level addresses (default). This is currently implemented for mapping between DARPA Internet addresses and IEEE 802 48-bit MAC addresses (Eth- ernet, FDDI, and Token Ring addresses). -arp Disable the use of the Address Resolution Protocol (arp(4)). staticarp If the Address Resolution Protocol is enabled, the host will only reply to requests for its addresses, and will never send any re- quests. -staticarp If the Address Resolution Protocol is enabled, the host will per- form normally, sending out requests and listening for replies. broadcast (Inet only.) Specify the address to use to represent broadcasts to the network. The default broadcast address is the address with a host part of all 1's. debug Enable driver dependent debugging code; usually, this turns on extra console error logging. -debug Disable driver dependent debugging code. promisc Put interface into permanently promiscuous mode. -promisc Disable permanently promiscuous mode. delete Another name for the -alias parameter. down Mark an interface "down". When an interface is marked "down", the system will not attempt to transmit messages through that in- terface. If possible, the interface will be reset to disable re- ception as well. This action does not automatically disable routes using the interface. eui64 (Inet6 only.) Fill interface index (lowermost 64bit of an IPv6 address) automatically. ipdst This is used to specify an Internet host who is willing to re- ceive IP packets encapsulating IPX packets bound for a remote network. An apparent point to point link is constructed, and the address specified will be taken as the IPX address and network of the destination. maclabel label If Mandatory Access Control support is enabled in the kernel, set the MAC label to label. media type If the driver supports the media selection system, set the media type of the interface to type. Some interfaces support the mutu- ally exclusive use of one of several different physical media connectors. For example, a 10Mb/s Ethernet interface might sup- port the use of either AUI or twisted pair connectors. Setting the media type to "10base5/AUI" would change the currently active connector to the AUI port. Setting it to "10baseT/UTP" would ac- tivate twisted pair. Refer to the interfaces' driver specific documentation or man page for a complete list of the available types. mediaopt opts If the driver supports the media selection system, set the speci- fied media options on the interface. The opts argument is a comma delimited list of options to apply to the interface. Refer to the interfaces' driver specific man page for a complete list of available options. -mediaopt opts If the driver supports the media selection system, disable the specified media options on the interface. mode mode If the driver supports the media selection system, set the speci- fied operating mode on the interface to mode. For IEEE 802.11 wireless interfaces that support multiple operating modes this directive is used to select between 802.11a ("11a"), 802.11b ("11b"), and 802.11g ("11g") operating modes. name name Set the interface name to name. rxcsum, txcsum If the driver supports user-configurable checksum offloading, en- able receive (or transmit) checksum offloading on the interface. Some drivers may not be able to enable these flags independently of each other, so setting one may also set the other. The driver will offload as much checksum work as it can reliably support, the exact level of offloading varies between drivers. -rxcsum, -txcsum If the driver supports user-configurable checksum offloading, disable receive (or transmit) checksum offloading on the inter- face. These settings may not always be independent of each other. vlanmtu, vlanhwtag If the driver offers user-configurable VLAN support, enable re- ception of extended frames or tag processing in hardware, respec- tively. Note that this must be issued on a physical interface associated with vlan(4), not on a vlan(4) interface itself. -vlanmtu, -vlanhwtag If the driver offers user-configurable VLAN support, disable re- ception of extended frames or tag processing in hardware, respec- tively. polling Turn on polling(4) feature and disable interrupts on the inter- face, if driver supports this mode. -polling Turn off polling(4) feature and enable interrupt mode on the in- terface. create Create the specified network pseudo-device. If the interface is given without a unit number, try to create a new device with an arbitrary unit number. If creation of an arbitrary device is successful, the new device name is printed to standard output un- less the interface is renamed or destroyed in the same ifconfig invocation. destroy Destroy the specified network pseudo-device. plumb Another name for the create parameter. Included for Solaris com- patibility. unplumb Another name for the destroy parameter. Included for Solaris compatibility. metric n Set the routing metric of the interface to n, default 0. The routing metric is used by the routing protocol (routed(8)). Higher metrics have the effect of making a route less favorable; metrics are counted as addition hops to the destination network or host. mtu n Set the maximum transmission unit of the interface to n, default is interface specific. The MTU is used to limit the size of packets that are transmitted on an interface. Not all interfaces support setting the MTU, and some interfaces have range restric- tions. netmask mask (Inet only.) Specify how much of the address to reserve for sub- dividing networks into sub-networks. The mask includes the net- work part of the local address and the subnet part, which is taken from the host field of the address. The mask can be speci- fied as a single hexadecimal number with a leading `0x', with a dot-notation Internet address, or with a pseudo-network name listed in the network table networks(5). The mask contains 1's for the bit positions in the 32-bit address which are to be used for the network and subnet parts, and 0's for the host part. The mask should contain at least the standard network portion, and the subnet field should be contiguous with the network portion. The netmask can also be specified in CIDR notation after the ad- dress. See the address option above for more information. prefixlen len (Inet6 only.) Specify that len bits are reserved for subdividing networks into sub-networks. The len must be integer, and for syntactical reason it must be between 0 to 128. It is almost al- ways 64 under the current IPv6 assignment rule. If the parameter is omitted, 64 is used. The prefix can also be specified using the slash notation after the address. See the address option above for more information. range netrange Under appletalk, set the interface to respond to a netrange of the form startnet-endnet. Appletalk uses this scheme instead of netmasks though FreeBSD implements it internally as a set of net- masks. remove Another name for the -alias parameter. Introduced for compati- bility with BSD/OS. phase The argument following this specifies the version (phase) of the Appletalk network attached to the interface. Values of 1 or 2 are permitted. link[0-2] Enable special processing of the link level of the interface. These three options are interface specific in actual effect, how- ever, they are in general used to select special modes of opera- tion. An example of this is to enable SLIP compression, or to select the connector type for some Ethernet cards. Refer to the man page for the specific driver for more information. -link[0-2] Disable special processing at the link level with the specified interface. monitor Put the interface in monitor mode. No packets are transmitted, and received packets are discarded after bpf(4) processing. -monitor Take the interface out of monitor mode. up Mark an interface "up". This may be used to enable an interface after an "ifconfig down". It happens automatically when setting the first address on an interface. If the interface was reset when previously marked down, the hardware will be re-initialized. The following parameters are specific to IEEE 802.11 wireless interfaces: apbridge When operating as an access point, pass packets between wireless clients directly (default). To instead let them pass up through the system and be forwarded using some other mechanism, use -apbridge. Disabling the internal bridging is useful when traf- fic is to be processed with packet filtering. authmode mode Set the desired authentication mode in infrastructure mode. Not all adaptors support all modes. The set of valid modes is "none", "open", "shared" (shared key), "8021x" (IEEE 802.1x), and "wpa" (IEEE WPA/WPA2/802.11i). The "8021x" and "wpa" modes are only useful when using an authentication service (a supplicant for client operation or an authenticator when operating as an ac- cess point). Modes are case insensitive. bintval interval Set the interval at which beacon frames are sent when operating in ad-hoc or ap mode. The interval parameter is specified in TU's (1/1024 msecs). By default beacon frames are transmitted every 100 TU's. bssid address Specify the MAC address of the access point to use when operating as a station in a BSS network. This overrides any automatic se- lection done by the system. To disable a previously selected ac- cess point, supply "any", "none", or "-" for the address. This option is useful when more than one access points have the same SSID. Another name for the bssid parameter is ap. chanlist channels Set the desired channels to use when scanning for access points, neighbors in an IBSS network, or looking for unoccupied channels when operating as an access point. The set of channels is speci- fied as a comma-separated list with each element in the list rep- resenting either a single channel number or a range of the form "a-b". Channel numbers must be in the range 1 to 255 and be per- missible according to the operating characteristics of the de- vice. channel number Set a single desired channel. Channels range from 1 to 255, but the exact selection available depends on the region your adaptor was manufactured for. Setting the channel to "0", "any", or "-" will give you the default for your adaptor. Some adaptors ignore this setting unless you are in ad-hoc mode. Alternatively the frequency, in megahertz, may be specified instead of the channel number. dtimperiod period Set the DTIM period for transmitting buffered multicast data frames when operating in ap mode. The period specifies the num- ber of beacon intervals between DTIM and must be in the range 1 to 15. By default DTIM is 1 (i.e. DTIM occurs at each beacon). fragthreshold length Set the threshold for which transmitted frames are broken into fragments. The length argument is the frame size in bytes and must be in the range 256 to 2346. Setting length to "2346", "any", or "-" disables transmit fragmentation. Not all adaptors honor the fragmentation threshold. hidessid When operating as an access point, do not broadcast the SSID in beacon frames or respond to probe request frames unless they are directed to the ap (i.e. they include the ap's SSID). By de- fault, the SSID is included in beacon frames and undirected probe request frames are answered. To re-enable the broadcast of the SSID etc., use -hidessid. list active Display the list of channels available for use taking into ac- count any restrictions set with the "chanlist" and "channel" di- rectives. list caps Display the adaptor's capabilities, including the operating modes supported. list chan Display the list of channels available for use. "list freq" is another way of requesting this information. list mac Display the current MAC Access Control List state. Each address is prefixed with a character that indicates the current policy applied to it: "+" indicates the address is allowed access, "-" indicates the address is denied access, "*" indicates the address is present but the current policy open (so the acl is not con- sulted). list scan Display the access points and/or ad-hoc neighbors located in the vicinity. This information may be updated automatically by the adaptor and/or with a "scan" request. "list ap" is another way of requesting this information. list sta When operating as an access point display the stations that are currently associated. When operating in ad-hoc mode display sta- tions identified as neighbors in the IBSS. list wme Display the current parameters to use when operating in WME mode. When WME mode is enabled for an adaptor this information will be displayed with the regular status; this command is mostly useful for examining parameters when WME mode is disabled. See the de- scription of the "wme" directive for information on the various parameters. powersave Enable powersave operation. When operating as a client, the sta- tion will conserve power by periodically turning off the radio and listening for messages from the access point telling it there are packets waiting. The station must then retrieve the packets. When operating as an access point, the station must honor power save operation of associated clients. Not all devices support power save operation, either as a client or as an access point. Use -powersave to disable powersave operation. powersavesleep sleep Set the desired max powersave sleep time in milliseconds. protmode technique For interfaces operating in 802.11g, use the specified technique for protecting OFDM frames in a mixed 11b/11g network. The set of valid techniques is "off", "cts" (CTS to self), and "rtscts" (RTS/CTS). Technique names are case insensitive. pureg When operating as an access point in 802.11g mode allow only 11g- capable stations to associate (11b-only stations are not permit- ted to associate). To allow both 11g and 11b-only stations to associate, use -pureg. roaming mode When operating as a station, control how the system will behave when communication with the current access point is broken. The mode argument may be one of "device" (leave it to the hardware device to decide), "auto" (handle either in the device or the op- erating system--as appropriate), "manual" (do nothing until ex- plicitly instructed). By default, the device is left to handle this if it is capable; otherwise, the operating system will auto- matically attempt to reestablish communication. Manual mode is mostly useful when an application wants to control the selection of an access point. rtsthreshold length Set the threshold for which transmitted frames are preceded by transmission of an RTS control frame. The length argument is the frame size in bytes and must be in the range 1 to 2346. Setting length to "2346", "any", or "-" disables transmission of RTS frames. Not all adaptors support setting the RTS threshold. ssid ssid Set the desired Service Set Identifier (aka network name). The SSID is a string up to 32 characters in length and may be speci- fied as either a normal string or in hexadecimal when preceded by `0x'. Additionally, the SSID may be cleared by setting it to `-'. scan Initiate a scan of neighboring stations, wait for it to complete, and display all stations found. Only the super-user can initiate a scan. Depending on the capabilities of the APs, the following flags can be included in the output: E Extended Service Set (ESS). Indicates that the station is part of an infrastructure network (in contrast to an IBSS/ad-hoc network). I IBSS/ad-hoc network. Indicates that the station is part of an ad-hoc network (in contrast to an ESS network). P Privacy. Data confidentiality is required for all data frames exchanged within the BSS. This means that this BSS requires the station to use cryptographic means such as WEP, TKIP or AES-CCMP to encrypt/decrypt data frames being ex- changed with others. S Short Preamble. Indicates that the network is using short preambles (defined in 802.11b High Rate/DSSS PHY, short pre- amble utilizes a 56 bit sync field in contrast to a 128 bit field used in long preamble mode). s Short slot time. Indicates that the network is using a short slot time. The "list scan" request can be used to show recent scan results without initiating a new scan. stationname name Set the name of this station. It appears that the station name is not really part of the IEEE 802.11 protocol though all inter- faces seem to support it. As such it only seems to be meaningful to identical or virtually identical equipment. Setting the sta- tion name is identical in syntax to setting the SSID. txpower power Set the power used to transmit frames. The power argument is a unitless value in the range 0 to 100 that is interpreted by driv- ers to derive a device-specific value. Out of range values are truncated. Typically only a few discreet power settings are available and the driver will use the setting closest to the specified value. Not all adaptors support changing the transmit power. wepmode mode Set the desired WEP mode. Not all adaptors support all modes. The set of valid modes is "off", "on", and "mixed". The "mixed" mode explicitly tells the adaptor to allow association with ac- cess points which allow both encrypted and unencrypted traffic. On these adaptors, "on" means that the access point must only al- low encrypted connections. On other adaptors, "on" is generally another name for "mixed". Modes are case insensitive. weptxkey index Set the WEP key to be used for transmission. wepkey key|index:key Set the selected WEP key. If an index is not given, key 1 is set. A WEP key will be either 5 or 13 characters (40 or 104 bits) depending of the local network and the capabilities of the adaptor. It may be specified either as a plain string or as a string of hexadecimal digits preceded by `0x'. For maximum portability, hex keys are recommended; the mapping of text keys to WEP encryption is usually driver-specific. In particular, the Windows drivers do this mapping differently to FreeBSD. A key may be cleared by setting it to `-'. If WEP is supported then there are at least four keys. Some adaptors support more than four keys. If that is the case, then the first four keys (1-4) will be the standard temporary keys and any others will be adap- tor specific keys such as permanent keys stored in NVRAM. wme Enable Wireless Multimedia Extensions (WME) support, if avail- able, for the specified interface. WME is a subset of the IEEE 802.11e standard to support the efficient communication of real- time and multimedia data. To disable WME support, use -wme. The following parameters are meaningful only when WME support is in use. Parameters are specified per-AC (Access Category) and split into those that are used by a station when acting as an ac- cess point and those for client stations in the BSS. The latter are received from the access point and may not be changed (at the station). The following Access Categories are recognized: AC_BE (or BE) best effort delivery, AC_BK (or BK) background traffic, AC_VI (or VI) video traffic, AC_VO (or VO) voice traffic. AC parameters are case-insensitive. Traffic classification is done in the operating system using the vlan priority associated with data frames or the ToS (Type of Service) indication in IP- encapsulated frames. If neither information is present traffic is assigned to the Best Effort (BE) category. ack ac Set the ACK policy for QoS transmissions by the local station; this controls whether or not data frames trans- mitted by a station require an ACK response from the re- ceiving station. To disable waiting for an ACK use -ack. This parameter is applied only to the local station. acm ac Enable the Admission Control Mandatory (ACM) mechanism for transmissions by the local station. To disable the ACM use -acm. On stations in a BSS this parameter is read-only and indicates the setting received from the ac- cess point. NB: ACM is not supported right now. aifs ac count Set the Arbitration Inter Frame Spacing (AIFS) channel access parameter to use for transmissions by the local station. On stations in a BSS this parameter is read- only and indicates the setting received from the access point. cwmin ac count Set the CWmin channel access parameter to use for trans- missions by the local station. On stations in a BSS this parameter is read-only and indicates the setting received from the access point. cwmax ac count Set the CWmax channel access parameter to use for trans- missions by the local station. On stations in a BSS this parameter is read-only and indicates the setting received from the access point. txoplimit ac limit Set the Transmission Opportunity Limit channel access pa- rameter to use for transmissions by the local station. This parameter defines an interval of time when a WME station has the right to initiate transmissions onto the wireless medium. On stations in a BSS this parameter is read-only and indicates the setting received from the ac- cess point. bss:aifs ac count Set the AIFS channel access parameter to send to stations in a BSS. This parameter is meaningful only when operat- ing in ap mode. bss:cwmin ac count Set the CWmin channel access parameter to send to sta- tions in a BSS. This parameter is meaningful only when operating in ap mode. bss:cwmax ac count Set the CWmax channel access parameter to send to sta- tions in a BSS. This parameter is meaningful only when operating in ap mode. bss:txoplimit ac limit Set the TxOpLimit channel access parameter to send to stations in a BSS. This parameter is meaningful only when operating in ap mode. The following parameters support an optional access control list feature available with some adaptors when operating in ap mode; see wlan_acl(4). This facility allows an access point to accept/deny association requests based on the MAC address of the station. Note that this feature does not significantly enhance security as MAC address spoofing is easy to do. mac:add address Add the specified MAC address to the database. Depending on the policy setting association requests from the specified station will be allowed or denied. mac:allow Set the ACL policy to permit association only by stations regis- tered in the database. mac:del Delete the specified MAC address from the database. mac:deny Set the ACL policy to deny association only by stations regis- tered in the database. mac:kick Force the specified station to be deauthenticated. This typi- cally is done to block a station after updating the address data- base. mac:open Set the ACL policy to allow all stations to associate. mac:flush Delete all entries in the database. The following parameters are for compatibility with other systems: nwid ssid Another name for the ssid parameter. Included for NetBSD compat- ibility. station name Another name for the stationname parameter. Included for BSD/OS compatibility. wep Another way of saying wepmode on. Included for BSD/OS compati- bility. -wep Another way of saying wepmode off. Included for BSD/OS compati- bility. nwkey key Another way of saying: "wepmode on weptxkey 1 wepkey 1:key wepkey 2:- wepkey 3:- wepkey 4:-". Included for NetBSD compatibility. nwkey n:k1,k2,k3,k4 Another way of saying "wepmode on weptxkey n wepkey 1:k1 wepkey 2:k2 wepkey 3:k3 wepkey 4:k4". Included for NetBSD compatibil- ity. -nwkey Another way of saying wepmode off. Included for NetBSD compati- bility. The following parameters are specific to bridge interfaces: addm interface Add the interface named by interface as a member of the bridge. The interface is put into promiscuous mode so that it can receive every packet sent on the network. deletem interface Remove the interface named by interface from the bridge. Promis- cuous mode is disabled on the interface when it is removed from the bridge. maxaddr size Set the size of the bridge address cache to size. The default is 100 entries. timeout seconds Set the timeout of address cache entries to seconds seconds. If seconds is zero, then address cache entries will not be expired. The default is 240 seconds. addr Display the addresses that have been learned by the bridge. static interface-name address Add a static entry into the address cache pointing to interface-name. Static entries are never aged out of the cache or re-placed, even if the address is seen on a different inter- face. deladdr address Delete address from the address cache. flush Delete all dynamically-learned addresses from the address cache. flushall Delete all addresses, including static addresses, from the ad- dress cache. discover interface Mark an interface as a "discovering" interface. When the bridge has no address cache entry (either dynamic or static) for the destination address of a packet, the bridge will forward the packet to all member interfaces marked as "discovering". This is the default for all interfaces added to a bridge. -discover interface Clear the "discovering" attribute on a member interface. For packets without the "discovering" attribute, the only packets forwarded on the interface are broadcast or multicast packets and packets for which the destination address is known to be on the interface's segment. learn interface Mark an interface as a "learning" interface. When a packet ar- rives on such an interface, the source address of the packet is entered into the address cache as being a destination address on the interface's segment. This is the default for all interfaces added to a bridge. -learn interface Clear the "learning" attribute on a member interface. stp interface Enable Spanning Tree protocol on interface. The if_bridge(4) driver has support for the IEEE 802.1D Spanning Tree protocol (STP). Spanning Tree is used to detect and remove loops in a network topology. -stp interface Disable Spanning Tree protocol on interface. This is the default for all interfaces added to a bridge. maxage seconds Set the time that a Spanning Tree protocol configuration is valid. The default is 20 seconds. The minimum is 1 second and the maximum is 255 seconds. fwddelay seconds Set the time that must pass before an interface begins forwarding packets when Spanning Tree is enabled. The default is 15 sec- onds. The minimum is 1 second and the maximum is 255 seconds. hellotime seconds Set the time between broadcasting of Spanning Tree protocol con- figuration messages. The default is 2 seconds. The minimum is 1 second and the maximum is 255 seconds. priority value Set the bridge priority for Spanning Tree. The default is 32768. The minimum is 0 and the maximum is 65536. ifpriority interface value Set the Spanning Tree priority of interface to value. The de- fault is 128. The minimum is 0 and the maximum is 255. ifpathcost interface value Set the Spanning Tree path cost of interface to value. The de- fault is 55. The minimum is 0 and the maximum is 65535. The following parameters are specific to IP tunnel interfaces, gif(4): tunnel src_addr dest_addr Configure the physical source and destination address for IP tun- nel interfaces. The arguments src_addr and dest_addr are inter- preted as the outer source/destination for the encapsulating IPv4/IPv6 header. -tunnel Unconfigure the physical source and destination address for IP tunnel interfaces previously configured with tunnel. deletetunnel Another name for the -tunnel parameter. The following parameters are specific to vlan(4) interfaces: vlan vlan_tag Set the VLAN tag value to vlan_tag. This value is a 16-bit num- ber which is used to create an 802.1Q VLAN header for packets sent from the vlan(4) interface. Note that vlan and vlandev must both be set at the same time. vlandev iface Associate the physical interface iface with a vlan(4) interface. Packets transmitted through the vlan(4) interface will be di- verted to the specified physical interface iface with 802.1Q VLAN encapsulation. Packets with 802.1Q encapsulation received by the parent interface with the correct VLAN tag will be diverted to the associated vlan(4) pseudo-interface. The vlan(4) interface is assigned a copy of the parent interface's flags and the par- ent's ethernet address. The vlandev and vlan must both be set at the same time. If the vlan(4) interface already has a physical interface associated with it, this command will fail. To change the association to another physical interface, the existing asso- ciation must be cleared first. Note: if the hardware tagging capability is set on the parent in- terface, the vlan(4) pseudo interface's behavior changes: the vlan(4) interface recognizes that the parent interface supports insertion and extraction of VLAN tags on its own (usually in firmware) and that it should pass packets to and from the parent unaltered. -vlandev [iface] If the driver is a vlan(4) pseudo device, disassociate the parent interface from it. This breaks the link between the vlan(4) in- terface and its parent, clears its VLAN tag, flags and its link address and shuts the interface down. The iface argument is use- less and hence deprecated. The ifconfig utility displays the current configuration for a network in- terface when no optional parameters are supplied. If a protocol family is specified, ifconfig will report only the details specific to that pro- tocol family. If the -m flag is passed before an interface name, ifconfig will display the capability list and all of the supported media for the specified in- terface. If -L flag is supplied, address lifetime is displayed for IPv6 addresses, as time offset string. Optionally, the -a flag may be used instead of an interface name. This flag instructs ifconfig to display information about all interfaces in the system. The -d flag limits this to interfaces that are down, and -u limits this to interfaces that are up. When no arguments are given, -a is implied. The -l flag may be used to list all available interfaces on the system, with no other additional information. Use of this flag is mutually ex- clusive with all other flags and commands, except for -d (only list in- terfaces that are down) and -u (only list interfaces that are up). The -v flag may be used to get more verbose status for an interface. The -C flag may be used to list all of the interface cloners available on the system, with no additional information. Use of this flag is mutually exclusive with all other flags and commands. The -k flag causes keying information for the interface, if available, to be printed. For example, the values of 802.11 WEP keys will be printed, if accessible to the current user. This information is not printed by default, as it may be considered sensitive. Only the super-user may modify the configuration of a network interface. NOTES The media selection system is relatively new and only some drivers sup- port it (or have need for it). DIAGNOSTICS Messages indicating the specified interface does not exist, the requested address is unknown, or the user is not privileged and tried to alter an interface's configuration. SEE ALSO netstat(1), carp(4), netintro(4), polling(4), vlan(4), rc(8), routed(8), sysctl(8) HISTORY The ifconfig utility appeared in 4.2BSD. BUGS Basic IPv6 node operation requires a link-local address on each interface configured for IPv6. Normally, such an address is automatically config- ured by the kernel on each interface added to the system; this behaviour may be disabled by setting the sysctl MIB variable net.inet6.ip6.auto_linklocal to 0. If you delete such an address using ifconfig, the kernel may act very oddly. Do this at your own risk. BSD October 1, 2005 BSD
NAME | SYNOPSIS | DESCRIPTION | NOTES | DIAGNOSTICS | SEE ALSO | HISTORY | BUGS
Want to link to this manual page? Use this URL:
<https://man.freebsd.org/cgi/man.cgi?query=ifconfig&sektion=8&manpath=FreeBSD+6.0-RELEASE>