FreeBSD Manual Pages
UHID(4) BSD Kernel Interfaces Manual UHID(4) NAME uhid -- USB generic HID support SYNOPSIS device uhid DESCRIPTION The uhid driver provides support for all HID (Human Interface Device) in- terfaces in USB devices that do not have a special driver. The device handles the following ioctl(2) calls: USB_GET_REPORT_ID (int) Get the report identifier used by this HID report. USB_GET_REPORT_DESC (struct usb_ctl_report_desc) Get the HID report descriptor. Using this descriptor the exact layout and meaning of data to/from the device can be found. The report descriptor is delivered without any processing. struct usb_ctl_report_desc { int size; u_char data[1024]; /* filled data size will vary */ }; USB_SET_IMMED (int) Sets the device in a mode where each read(2) will return the cur- rent value of the input report. Normally a read(2) will only re- turn the data that the device reports on its interrupt pipe. This call may fail if the device does not support this feature. USB_GET_REPORT (struct usb_ctl_report) Get a report from the device without waiting for data on the in- terrupt pipe. The report field indicates which report is re- quested. It should be UHID_INPUT_REPORT, UHID_OUTPUT_REPORT, or UHID_FEATURE_REPORT. This call may fail if the device does not support this feature. struct usb_ctl_report { int report; u_char data[1024]; /* used data size will vary */ }; USB_SET_REPORT (struct usb_ctl_report) Set a report in the device. The report field indicates which re- port is to be set. It should be UHID_INPUT_REPORT, UHID_OUTPUT_REPORT, or UHID_FEATURE_REPORT. This call may fail if the device does not support this feature. Use read(2) to get data from the device. Data should be read in chunks of the size prescribed by the report descriptor. Use write(2) to send data to the device. Data should be written in chunks of the size prescribed by the report descriptor. FILES /dev/uhid? SEE ALSO usbhidctl(1), uhidev(4), usb(4) HISTORY The uhid driver appeared in NetBSD 1.4. This manual page was adopted from NetBSD by Tom Rhodes <trhodes@FreeBSD.org> in April 2002. BSD July 12, 1998 BSD
NAME | SYNOPSIS | DESCRIPTION | FILES | SEE ALSO | HISTORY
Want to link to this manual page? Use this URL:
<https://man.freebsd.org/cgi/man.cgi?query=uhid&sektion=4&manpath=FreeBSD+6.0-RELEASE>